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cPet Desktop: FlexFile & Quantity Data Preparer Guide

This cPet Desktop Guide will enable the 
Industry Preparer to execute the following:

› Use FlexFile & Quantity Excel Templates to 
Generate JSON Submission Files

› Populate CSDR Plan Metadata into FlexFile & 
Quantity Templates

› Validate File Format against the File Format 
Specifications

› Validate FlexFile & Quantity JSON Files against 
the approved CSDR (DD 2794) Plan

› Create & View Legacy 1921 formats

› View Government Reviewer “Pivot” Exports 
Prior to Submission

Quick Links:

• Getting Started

• Generating a FlexFile JSON File

• Generating a Quantity JSON File

• FlexFile and Quantity Data & CSDR 
Plan Validation

• Generating Submission Reviewer 
Files 1921 Legacy & FlexFile Pivot

For additional implementation & training 
materials:
https://cade.osd.mil/policy/flexfile-quantity

https://cade.osd.mil/policy/flexfile-quantity
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Creating Cost and Hour Report (FlexFiles) and Quantity Data Reports
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• As an Industry Data Preparer, there are multiple features within cPet Desktop to assist users in the creation and 
validation of the FlexFile and Quantity Reports

• Key cPet Functions:

• Create FlexFile & Quantity Excel Template from CSDR Plan

• Import FlexFile & Quantity Excel Templates and Validate Format against File Format Specification (FFS)

• Generate JSON FlexFile & Quantity Submission Zip File Formats

• Generate Legacy 1921 and FlexFile Pivot “Reviewer” Files

• Validate FlexFile & Quantity Formats against 2019 FlexFile CSDR Plan

CREATE

• Multi-Part 
Template

• Excel 
Template

DATA MODEL

• Complete 
the Excel 
template 

IMPORT

• Convert 
Excel 
template to 
JSON

VALIDATE

• Use cPet  to 
check for 
validation 
errors

SUBMIT

• Successful 
submission 
into CSDR-
SR

Getting Started

Complete Data 
Model/Template

Import Excel 
Template
into cPet

Validate FlexFile & 
Quantity Data 

Reports

Create FlexFile & 
Q Excel 

Templates



Getting Started: Process Overview
cPet Desktop: FlexFile & Quantity Data Preparer Guide

Upload XML Plan 

 User can create an empty Excel template with 
information from the XML CSDR Plan

 Upload XML plan into cPet and generate an empty Excel 
template

 These templates will contain information from the plan 
 Basic Metadata 
 WBS Structure
 Order/Lots (as identified by the plan)
 End Items (as identified by the plan) 

 User then imports a completed Excel template to 
generate the JSON file 

 cPet will generate errors to show where the imported 
file does not adhere to the DEI/FFS

 Once the errors are corrected, cPet will generate a 
JSON file that adheres to the DEI/FFS & can be ingested 
into CADE

 Upload the JSON file to CADE
Upload Filled out Excel 

Template

4
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Getting Started: Downloading cPet
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• Navigate to the CADE Tools  page 
(https://cade.osd.mil/tools/csdr-
tools) and scroll down to the Cost 
Planning & Execution Tool (cPET)

• Under the cPet section, users can 
click on a link to download cPet

• Users will be directed to the cPet 
Download registration page

• Enter POC information and click 
Submit

• Follow the directions on how to 
download the cPet from the zip file 
located on the page

Getting Started
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Model/Template

Import Excel 
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Validate FlexFile & 
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Reports
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https://cade.osd.mil/tools/csdr-tools


Generating a 

FlexFile JSON File
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Step 1: Access the Flex File Conversion Tool
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• In order to create the FlexFile Excel templates, the user must access the Flex File Conversion Tool 

• Click Tools > Convert FlexFile
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Excel Template Creation Options
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• The user has the option to generate the FlexFile JSON file using one of two Excel template options:

Getting Started

Complete Data 
Model/Template

Import Excel 
Template
into cPet

Validate FlexFile & 
Quantity Data 

Reports

Create FlexFile & 
Q Excel 

Templates

1 2

1 2Multi-Part Excel Template:
• Breaks the required format tables into three parts:

1. FlexFile Template Part 1 – Metadata & Structures
2. FlexFile Template Part 2 – Actual Cost-Hour Data
3. FlexFile Template Part 3 – Supplemental Data

• Allows for one-time creation of Part I & III for 
initial submission, with updates to Part II, only for 
subsequent submissions

• Breaks the format validation errors into smaller, 
manageable reports

Excel Template:
• Includes ALL required tables in one Excel file
• Version control narrowed down to a single file
• Format error reporting extended to all tables

*Instructions in this guide will cover 1. 
Multi-Part Excel Template, but can 

easily be applied to 2. Excel Template
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Step 2: Create FlexFile Excel Template from Contract Plan
cPet Desktop: FlexFile & Quantity Data Preparer Guide

Begin by creating the FlexFile template: 

• The user can create a Multi-Part Excel Template
from the approved CSDR (DD2794) XML Plan 
which will generate the following templates in 
Excel: 

1. FlexFile Template Part 1 – Metadata & 
Structures

2. FlexFile Template Part 2 – Actual Cost-
Hour Data

3. FlexFile Template Part 3 – Supplemental 
Data

• To create, click Browse > Select XML DD 2794 
Plan > Create
• cPet will save the Excel templates to the 

original file where the user retrieved the 
DD2794 source file 

Getting Started
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Step 3: Completing the Multi-Part Excel FlexFile Template
cPet Desktop: FlexFile & Quantity Data Preparer Guide
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Note:
For more detail on completing the Multi-Part Part 

Template, users can view the Cost and Hour Report 
(FlexFile) Data Item Description, FlexFile & Quantity 

Implementation Guide, FlexFile File Format 
Specification(FFS) and the FlexFile Data Exchange 

Instructions (DEI) – located on the CADE public website: 
https://cade.osd.mil/policy/flexfile-quantity

Getting Started

Complete Data 
Model/Template

Import Excel 
Template
into cPet

Validate FlexFile & 
Quantity Data 

Reports

Create FlexFile & 
Q Excel 

Templates

• Using the CSDR Plan, cPet will auto-populate a subset of the required Metadata, WBS, End Item, and 
Order/Lot fields as a starting point; it’s now up to the user to complete the other required tables:

https://cade.osd.mil/policy/flexfile-quantity


Step 4: File Format Validation
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• Once the Multi-Part Excel template is 
complete, the user can now Import
the completed Multi-Part Excel 
Template into cPet to generate the 
FlexFile Import Error Log

• Make sure Import is selected: Click
Browse > Select File & Upload > Import

• cPet will generate an Excel report to 
show where the imported file does 
not adhere to the DEI/FFS

• This report will be located in the 
source folder where the templates are 
stored on the user’s hard drive

A JSON file will not generate unless the files are compliant with the DEI/FFS

Getting Started
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Model/Template
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into cPet

Validate FlexFile & 
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Reports

Create FlexFile & 
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Step 5: File Format Validation: Error Reporting
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• The format validation error report will generate 
an Import Error Log by error type, as defined in 
the Data Exchange Instructions (DEI) and File 
Format Specification (FFS)

• The error report will identify the error type, as 
well as the table and cell where the error exists

• The user must correct all identified errors listed 
by type across the identified tables and cells

• When all errors identified by the single error 
type are complete, the user must re-upload the 
Excel templates to generate the next error type

• The user should repeat this process until cPet 
does not identify any additional errors

* See next slide for an entire list of the errors 
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FlexFile Format Errors
cPet Desktop: FlexFile & Quantity Data Preparer Guide
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Error Explanation Example

Invalid ID reference
A foreign key was reported that is not found in the
corresponding data table

End Item ID “4” was reported in the Actual Cost Hour data table but 
was not found in the CLIN data table

Text value expected
The value reported is not a text value (i.e. string or string 
ID)

End Item ID “3” is being read in as the number 3 as opposed to a 
text value “3”

Integer value is expected The value reported is not an integer
Reporting Period ID is being read in as “1” as opposed to the 
number 1

String value has invalid whitespace
The value reported has two or more consecutive 
whitespaces, whitespace at the beginning or end of the 
string

End Item Name “Variant A” has two spaces between the “Variant” 
and the “A”

Required field is empty
There is a blank value in a field that is identified as non-
nullable by the FFS

End Item ID in the Actual Cost Hour data table is identified as non-
nullable by the FFS

Conditionally required field is empty
There is a field that was left empty that is identified as 
conditional

If the contractor does not identify a Unit or Sublot ID in the Actual 
Cost Hour data table, then End Item ID must not be null

Conditionally prohibited field is not empty There is a value in a field that is identified as conditional
If the contractor does identify a Unit Or Sublot ID in the Actual Cost 
Hour data table, then End Item ID must be null

Invalid Cost-Hour Datum WBS Element ID
Costs are being reported to a parent level WBS Element ID 
in the Actual Cost Hour table

Costs are being reported to WBS Element ID 1.1 when 1.1.1 is the 
lowest level of the WBS

Record is not unique
The same record is reported for a field that is identified as a 
primary key in the FFS

Account ID “000001” is reported twice in the Account data table

Invalid Reporting Period Start Date
The start date must be 1 day later than the end date of the 
previous record

The End Date of the previous record is 2/29/2016 and the next Start 
Date is 3/3/2016

Invalid Reporting Period ID
The order of record is significant for the reporting period 
and the records must have a sequential ID with the values 
starting at 1

The reporting period does not start at 1 OR the reporting period is
not in sequential order 1, 2, 3, etc.

Invalid Allocation Component Percent Value 
If the allocation method type is identified as “Percent” then 
the corresponding Percent Value must be greater than zero

You cannot have a negative percent identified in the Percent Value 
field in the Allocation Components table if “Percent” is identified in 
the Allocation Method Type field in the AllocationMethod Table

Invalid Reporting Element ID
The corresponding Parent Element identified incorrectly for 
the WBS Structure 

The WBS Element ID is 1.1.1 and the Parent ID is 1.2 OR if the 
incorrect WBS Level is identified 

Getting Started
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Reports
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Step 6: JSON Format Creation
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• Once all identified errors have been addressed, and the Excel templates must be re-imported into the Conversion 
tool via Browse > Select File & Upload > Import

• cPet will generate a zipped JSON file that adheres to the DEI/FFS and can be ingested into CADE

• The JSON zipped file will auto-generate within the same source folder used to upload the Excel templates, which will 
be the official submission file

Getting Started

Complete Data 
Model/Template

Import Excel 
Template
into cPet

Validate FlexFile & 
Quantity Data 

Reports

Create FlexFile & 
Q Excel 

Templates



Generating a 

Quantity Data JSON File
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Step 1: Access the Quantity Report Conversion Tool
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• In order to create the Quantity Data Report in Excel, the user must access the Quantity Data Report Conversion Tool

• Click Tools > Convert Quantity Report 

Getting Started

Complete Data 
Model/Template

Import Excel 
Template
into cPet

Validate FlexFile & 
Quantity Data 

Reports

Create FlexFile & 
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Step 2: Create Quantity Excel Template from CSDR Plan
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• The user can create a Quantity 
Excel Template from the approved 
CSDR (DD2794) XML Plan

• To create, click Browse > Select 
XML DD2794 Plan > Create
• cPet will save the Excel 

templates to the original 
file where the user 
retrieved the DD 2794 
source file 

Getting Started

Complete Data 
Model/Template

Import Excel 
Template
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Validate FlexFile & 
Quantity Data 

Reports
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Step 3: Completing the Quantity Data Excel Template
cPet Desktop: FlexFile & Quantity Data Preparer Guide
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Note:
For more detail on completing the Quantity 
Data Report, please read the Quantity Data 

Report Data Item Description (DID), Quantity 
File Format Specification and Quantity Data 
Exchange Instructions located on the CADE 

Public site: 
https://cade.osd.mil/policy/flexfile-quantity

Getting Started

Complete Data 
Model/Template

Import Excel 
Template
into cPet

Validate FlexFile & 
Quantity Data 

Reports

Create FlexFile & 
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Templates

• Using the CSDR Plan, cPet will auto-populate a subset of the required Metadata, WBS, End Item, and 
Order/Lot fields as a starting point; it’s now up to the user to complete the other required tables:

https://cade.osd.mil/policy/flexfile-quantity
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Step 4: File Format Validation
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• Once the Excel template is 
complete, the user can now 
Import the completed Quantity 
Excel Template into cPet to 
generate the Quantity Import 
Error Log

• Make sure Import is selected: 
Click Browse > Select File & 
Upload > Import

• cPet will generate an Excel report 
to show where the imported file 
does not adhere to the DEI/FFS

• This report will be located in the 
source folder where the 
templates are stored on the 
user’s hard drive

A JSON file will not generate unless the files are compliant with the DEI/FFS
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Validate FlexFile & 
Quantity Data 

Reports

Create FlexFile & 
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Step 5: File Format Validation: Error Reporting
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• The format validation error report will generate 
an Import Error Log by error type, as defined in 
the Data Exchange Instructions (DEI) and File 
Format Specification (FFS)

• The error report will identify the error type, as 
well as the table and cell where the error exists

• The user must correct all identified errors listed 
by type across the identified tables and cells

• When all errors identified by the single error 
type are complete, the user must re-upload the 
Excel templates to generate the next error type

• The user should repeat this process until cPet 
does not identify any additional errors

* See next slide for an entire list of the errors 
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Quantity Format Errors
cPet Desktop: FlexFile & Quantity Data Preparer Guide
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Error Explanation Example

Invalid ID reference
A foreign key was reported that is not found in the
corresponding data table

End Item ID “4” was reported in the Actual Cost Hour data table but 
was not found in the CLIN data table

Text value expected
The value reported is not a text value (i.e. string or string 
ID)

End Item ID “3” is being read in as the number 3 as opposed to a 
text value “3”

Integer value is expected The value reported is not an integer
Reporting Period ID is being read in as “1” as opposed to the 
number 1

String value has invalid whitespace
The value reported has two or more consecutive 
whitespaces, whitespace at the beginning or end of the 
string

End Item Name “Variant A” has two spaces between the “Variant” 
and the “A”

Required field is empty
There is a blank value in a field that is identified as non-
nullable by the FFS

End Item ID in the Actual Cost Hour data table is identified as non-
nullable by the FFS

Conditionally required field is empty
There is a field that was left empty that is identified as 
conditional

If the contractor does not identify a Unit or Sublot ID in the Actual 
Cost Hour data table, then End Item ID must not be null

Conditionally prohibited field is not empty There is a value in a field that is identified as conditional
If the contractor does identify a Unit Or Sublot ID in the Actual Cost 
Hour data table, then End Item ID must be null

Invalid Cost-Hour Datum WBS Element ID
Costs are being reported to a parent level WBS Element ID 
in the Actual Cost Hour table

Costs are being reported to WBS Element ID 1.1 when 1.1.1 is the 
lowest level of the WBS

Record is not unique
The same record is reported for a field that is identified as a 
primary key in the FFS

Account ID “000001” is reported twice in the Account data table

Invalid Reporting Period Start Date
The start date must be 1 day later than the end date of the 
previous record

The End Date of the previous record is 2/29/2016 and the next Start 
Date is 3/3/2016

Invalid Reporting Period ID
The order of record is significant for the reporting period 
and the records must have a sequential ID with the values 
starting at 1

The reporting period does not start at 1 OR the reporting period is
not in sequential order 1, 2, 3, etc.

Invalid Allocation Component Percent Value 
If the allocation method type is identified as “Percent” then 
the corresponding Percent Value must be greater than zero

You cannot have a negative percent identified in the Percent Value 
field in the Allocation Components table if “Percent” is identified in 
the Allocation Method Type field in the AllocationMethod Table

Invalid Reporting Element ID
The corresponding Parent Element identified incorrectly for 
the WBS Structure 

The WBS Element ID is 1.1.1 and the Parent ID is 1.2 OR if the 
incorrect WBS Level is identified 
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Step 6: JSON Format Creation
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• Once all identified errors have been addressed, and the Excel templates must be re-imported into the Conversion 
tool via Browse > Select File & Upload > Import

• cPet will generate a zipped JSON file that adheres to the DEI/FFS and can be ingested into CADE

• The JSON zipped file will auto-generate within the same source folder used to upload the Excel templates, which will 
be the official submission file
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FlexFile and Quantity

Data & CSDR Plan Validation
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Step 1: Upload CSDR Plan & FF/Q JSON Files
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• cPet allows the user to pre-validate 
data within the FlexFile & Quantity 
JSON files prior to submission in 
CADE

• Select Tools > Validate FlexFile & 
Quantity Report

• Browse and upload the FlexFile & 
Quantity Data Report JSON files

• Browse > Select File & Upload > 
Validate

• User will be prompted to save 
down the Validation Results in an 
Excel file within the source folder Note:

Users can still validate the 
FlexFile if a  Quantity Data 

Report is not available

Getting Started
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FlexFile & Quantity Data Validation Errors
cPet Desktop: FlexFile & Quantity Data Preparer Guide
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Validation Type Error Message Severity 

FlexFile Internal Summary cost records must be included for all Orders/Lots. Major

FlexFile Internal Reported summary cost values must match calculated summary cost values. Major

FlexFile Internal Reporting calendar must not exceed contractual period of performance. Major

FlexFile Internal Reporting periods must be between 20 and 40 days in length. Major

FlexFile Internal Units/Sublots must have valid unit number ranges. Major

FlexFile Internal Unit/Sublot unit number ranges for a given End Item must not overlap. Major

FlexFile vs Plan Each reported Order/Lot must be identified in the CSDR Plan. Major

FlexFile vs Plan Each reported End Item must be identified in the CSDR Plan. Major

FlexFile vs Plan Each reported WBS Element must be identified in the CSDR Plan. Major

FlexFile vs Plan Each WBS Element indicated in the CSDR Plan must be included. Major

FlexFile vs Plan WBS parent elements must match those identified in the CSDR Plan. Major

FlexFile vs Plan At least two Units/Sublots must be reported for each pair of Order/Lot and End Item indicated in the CSDR Plan. Major

Quantity Internal Production Sequence Segments must have valid unit number ranges. Major

Quantity Internal Production Sequence Segment unit number ranges for a given End Item must not overlap. Major

Quantity vs Plan Each reported Order/Lot must be identified in the CSDR Plan. Major

Quantity vs Plan Each reported End Item must be identified in the CSDR Plan. Major

Quantity vs Plan Each reported WBS Element must be identified in the CSDR Plan. Major

Quantity vs Plan Each WBS Element indicated in the CSDR Plan must be included. Major

Quantity vs Plan WBS parent elements must match those identified in the CSDR Plan. Major

Quantity vs Plan At least one Production Sequence Segment must be reported for each pair of Order/Lot and End Item indicated in the CSDR Plan. Major
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Step 2: Viewing the Validation Error Results 
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• The Validation 
Results will list all 
errors, as well as 
the severity

• Any error identified 
as Major could 
result in a rejection 
from DCARC

• The user should 
attempt to address 
all errors prior to 
submission of the 
JSON files in CADE
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Generating Submission Reviewer Files

1921 Legacy & FlexFile Pivot
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Submit-Review Government Reviewer Files
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• When the FlexFile & Quantity JSON files are submitted and validated in CADE’s CSDR Submit-Review 
application, Government Reviewer Files are generated:
• FlexFile Pivot Data
• Legacy 1921 views by Order/Lot

• These files will be used to review the submitted data
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Submit-Review Government Reviewer Files: Legacy 1921
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• The legacy 1921 format is generated 
to verify that the FlexFile and Quantity 
data can be summarized at the same 
level as the historical data

• Data Submitters and Reviewers have 
access to view the following:
• User Interface view of the 1921
• Excel export of the 1921
• Flat file export of the 1921
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Submit-Review Government Reviewer Files: FlexFile Pivot
cPet Desktop: FlexFile & Quantity Data Preparer Guide

FlexFile Pivot Export 
flattens (de-normalizes) 
the structured data in the 
FlexFile

• Supports 
filtering & pivot 
table creation

• Repeats values 
on every row 
(de-normalized)

• Requires 
familiarity to 
source/intent of 
specific columns 
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Generating & Viewing Legacy 1921 XML in cPet
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• cPet allows the user to generate the 1921 data to view, validate, and verify prior to submission of the 
FlexFile & Quantity JSON formats

• Click Tools > Convert FlexFile > Select the CCDR XML tab

• Browse and upload your CSDR Cost and Hour Report (Flex File) and CSDR Quantity Data Report (If you have 
a Flex File generated, you do not need to upload a Quantity Data Report) > Click Export

• The 1921 files will save down as XML files within the user’s source folder. 
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Generating & Viewing Legacy 1921 XML in cPet
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• In order to view your 1921, 
you will need to have your 
DD2794 CSDR plan uploaded 
within cPet.  

• Drag and drop your 1921 XML 
files that you generated from 
your FlexFile against your 
uploaded CSDR plan

• Go to Tools > Export DD2794
OR Right click on your 
uploaded 1921 > Click Export 
DD Form

• You will now be able to view 
your legacy 1921 in it’s Excel 
format located in the source 
folder where the 1921 XML 
files were stored on the user’s 
hard drive.
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Generating & Verifying FlexFile Pivot Data in cPet 
cPet Desktop: FlexFile & Quantity Data Preparer Guide

• cPet allows the user to 
generate the FlexFile Pivot 
data to view and verify prior 
to submission of the FlexFile 
& Quantity JSON formats

• From the FlexFile Conversion 
tool, ensure Pivot Data is 
selected:
• Click Browse > Select 

FlexFile JSON File> Click 
Export

• User will be prompted to save 
the FlexFile Pivot Data in an 
Excel file within the source 
folder
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